Thursday, March 20, 2008

IE7 Loading Slow for You? Here's a fix that may work...

For a while now, Internet Explorer 7 has been sluggish to load, open new windows, and create new tabs. I had put up with it for some time because although I'd fire it up to go to certain sites (like my company's Sharepoint portal), it wasn't my daily browser. That was a role filled by Firefox.

I suspected that the issue lied with an installed add-on, as Firefox problems usually spawn from a misbehaving extension. I've disabled add-ons in the past, but I hadn't found the right one.

That changed today when I disabled the "SSVHelper Class." This component is apparently related to Java 6, update 2, and apparently has a bug that's been squashed. Oddly enough, the fix hasn't been deployed (or at least not to me) as I've been putting up with this slowness for almost a year now.

Anyway, if you're experiencing slowness with IE, try disabling the add-on. It's a completely reverse able exercise, and it may resolve your troubles:

  1. In IE, go to Tools > Manage Add-ons > Enable or Disable Add-ons

  2. In the window that opens, select "Add-ons currently loaded in Internet Explorer."

  3. Under the "Enabled" section, select the "SSVHelper Class." You'll see that the publisher is "(Not verified) Sun Microsystems, Inc."

  4. With the add-on selected, click the "Disable" radio button at the bottom of the window, then click "OK."

  5. Restart Internet Explorer.

That's it. Hopefully you'll see the same results as I did. The browser is now a lot snappier that in used to be.

Labels: , , ,

7 Comments:

Blogger James said...

Wonderful fix. Thank you. I have been trying everything with zero conclusion. This simple fix made it much better. I have noticed that "Add-ons" have caused me problems with IE7 before.

Tue Aug 05, 03:15:00 PM PDT  
Blogger brad77 said...

Glad to help! Unfortunately, poorly written add-ons can have a similar effect on IE as bad extensions do Firefox. For IE, however, it seems that add-ons often get installed without notifying you, requiring that you double-check your add-ons list from time to time even if you don't remember installing any.

Thu Aug 07, 01:58:00 AM PDT  
Anonymous Anonymous said...

Thank you! This fixed my problem instantly!

Thu Nov 06, 11:43:00 AM PST  
Anonymous Anonymous said...

Awesome mate. It worked perfect. An end to the major pain (hopefully)

Mon Jan 12, 02:29:00 AM PST  
Blogger Amanda said...

Yippee! Thanks so much for this tip! It worked beautifully...as I've been W.A.I.T.I.N.G. for IE to load for months now and hated it. Just never had time to fix it. :)

Mon Jun 15, 11:43:00 AM PDT  
Anonymous Anonymous said...

Thanxx a Lot !!!!!!!!!!!!! problem has been solved !

Mon Aug 17, 05:53:00 AM PDT  
Anonymous Anonymous said...

Thanx a Lot !!!!! Problem has been solved !

Mon Aug 17, 05:54:00 AM PDT  

Post a Comment

Links to this post:

Create a Link

<< Home